DataNet Quality Systems Knowledgebase

What do each of the different user permissions do?

Permission

When this permission is granted, WinSPC allows the user to ...

Screen Print

Access the "File" > "Print Window" drop down item, which allows the user to
print the exact window as seen in Data Collection.

Resize Data Collection Form

Resize the Data Collection form.

Screen Elements (View)

Access the "View" drop down in the Data Collection window. The items in
this drop down allow the user to turn the Data Collection screen elements
on or off.

Screen Elements (View) > Data
Entry

Access the "View" > "Data Entry - Standard", "Data Entry - Spreadsheet",
and "Data Entry - Blueprint" drop down items. These items allow the user to
turn the Data Entry area (standard, spreadsheet, or blueprint) on or off.

Screen Elements (View) >
Charts

Access the "View" > "Charts" drop down item. This item allows the user to
turn the chart on or off in Data Collection.

Screen Elements (View) >
Status Bar

Access the "View" > "Status Bar" drop down item. This item allows the user
to turn the status bar (located at the bottom of the screen) on or off in Data
Collection.

Screen Elements (View) > Tool
Bar

Access the "View" > "Tool Bar" drop down item. This item allows the user to
turn the tool bar (located at the top of the screen) on or off in Data
Collection.

Screen Elements (View) >
Ribbon

Access the "View" > "Ribbon" drop down item. This item allows the user to
turn the ribbon (containing the part name, variable name, and last subgroup
status) on or off in Data Collection.

Status Bar Settings

Change the items displayed on the status bar (this is done by right-clicking
on the status bar and selecting "Properties"). The sub-items in this
permission category allows an administrator to restrict exactly what status
bar elements the user can and cannot display.

Clear Spreadsheet And
Blueprint Data Entry

Use the "Clear" button to remove all readings in the spreadsheet and
blueprint Data Collection mode that have not yet been saved to the main
WinSPC database.

Next Characteristic

Access the "Characteristic" > "Skip" drop down option and the "Next
Characteristic" button in Data Collection to move to the next characteristic in
sequential mode.

Previous Characteristic

Access the "Characteristic" > "Skip Back" drop down option and the
"Previous Characteristic” button in Data Collection to move to the previous
characteristic in sequential mode.

Recalculate Control Limits

Access the "Options" > "Recalculate Control Limits" drop down option and
the "Recalculate Control Limits" button, which when activated, forces
WinSPC to recalculate the control limits based upon the control limit settings
in the characteristic setup. While this change is effective immediately, the
changes in the control limits are not visible on the chart until another
subgroup of data is collected.

1/7




Reset Control Limits

Access the "Options" > "Reset Control Limits" drop down option and the
"Reset Control Limits" button, which when activated, sets the control limits
of the current characteristic back to their default value. While this change is
effective immediately, the changes in the control limits are not visible on the
chart until another subgroup of data is collected.

Random Characteristic
Selection

Access the drop down in the tool bar containing the list of characteristics in
the collection plan. This list allows the user to move directly to any
characteristic in the current visual group. If the current step is configured to
be in "Random" mode, then this is the method the user will use to change to
a different step in the collection plan.

Manual Tag Access

Access the "Edit Tag Values" button in the toolbar, giving the user the ability
to modify the tag values saved for future subgroups.

View Specifications

Access the "View Specs" button in the toolbar, giving the user the ability to
see the current reasonable limits, specification limits, and target for the
current characteristic (variables only).

View Specifications > Edit
Specifications

Edit the value of any reasonable limits, specification limits, or target that are
set to be "Constant” in the variable setup. While this change is effective
immediately, the changes in the limits are not visible on the chart until
another subgroup of data is collected.

Current Sample Data Edit

Edit the samples of data that have not yet been uploaded to the main
WinSPC database and plotted on the chart. These samples are stored in
the "Data Entry" panel in Data Collection.

Edit Data

Edit the samples of a subgroup that has already been collected and plotted
on the chart.

Edit Tags

Edit the tag values of a subgroup that has already been collected and
plotted on the chart.

Chart Drill Down

Click on a subgroup of data on the chart and see the "Chart Drill Down"
window, showing the samples associated with the subgroup, any subgroup
violations, subgroup tag values, and any notes, assignable causes, or
corrective actions associated with the subgroup.

Chart Drill Down > Exclude
from Calculations

Access the "Exclude From Calculations” checkbox in the "Chart Drill Down"
window, which when activated, will mark the subgroup as excluded from
calculations. This permission also allows the user to use the "Options" >
"Excluded From Calculations" drop down item and "Exclude Last Subgroup
from Calculations" button in the toolbar, which when activated, will exclude
the last subgroup visible on the chart.

Chart Drill Down > Edit Notes

Edit the notes, assignable causes, and corrective actions associated with
the subgroup.

Change Password

Access the "Options" > "Change Password" drop down item, giving the user
the ability to change their own password.

Data Collection By Item

Access the "File" > "Data Collection By Item" drop down item, which when
activated, allows the user to search for other parts or characteristics to
collect data into (through the use of a dynamic collection plan).

Permission

When this permission is granted, WinSPC allows the user to ...

Remove events from the Event
Log

Access the "Events" > "Delete Selected Events" drop down menu item from
within the "Event Log" window, giving the user the ability to permanently
remove the selected events from the event log.
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Archive / Restore

Access the "File" > "Archive" and "File" > "Restore" drop down menu items
in the "Administrator" window, giving the user the ability to create and
execute archives and restores.

Access the "File" > "Import" drop down menu item in the "Administrator"

Import window, giving the user the ability to import a .csv file containing part setup
information (specs) or data.
Access the "File" > "Export" drop down menu item in the "Administrator"”
Export window, giving the user the ability to export a .csv file containing part setup

information (specs) or data.

Navigator Setup

Access the "Tools" > "Navigator Setup" drop down menu item in the
"Administrator” window, giving the user the ability to modify the global
"Navigator" settings, such as the button icons and labels.

License Manager

Access the "Tools" > "License Manager" drop down menu item in the
"Administrator" window, giving the user the ability to activate purchased
licenses.

Add Language

Access the "Tools" > "Add Language" drop down menu item in the
"Administrator" window, giving the user the ability to add additional
language packs to WinSPC.

Change Server Login

Access the "Tools" > "Change Server Login" drop down menu item in the
"Administrator" window, giving the user the ability to change the database
username and password used by WinSPC.

Migrate

Access the "Tools" > "Migrate" drop down menu item in the "Administrator"
window, giving the user the ability to move the WinSPC database from one
server to another.

Reset Collection Plans /
Stations

Access to the "Reset" option when right-clicking on a Collection Plan or
Station in the "Administrator” window. Resetting a collection plan or station
will release any object locks that may have been caused by an improper
shutdown of WinSPC.

Create Parts and Folders

Create new parts, part folders, variables, attributes, tags, and blueprints.

Edit Parts and Folders

Edit any existing part, part folder, variable, attribute, tag, or blueprint.

Delete Parts and Folders

Delete any existing part, part folder, variable, attribute, tag, or blueprint.

Create Short Run Processes
and Folders

Create new short run processes, short run process folders, and short run
tags.

Edit Short Run Processes and
Folders

Edit any existing short run process, short run folder, or short run tag.

Delete Short Run Processes
and Folders

Delete any existing short run process, short run folder, or short run tag.

Create Collection Plans and
Folders

Create new collection plans and collection plan folders.

Edit Collection Plans and
Folders

Edit any existing collection plan or collection plan folder.

Delete Collection Plans and
Folders

Delete any existing collection plan or collection plan folder.

Create Devices and Folders

Create new devices and device folders.

Edit Devices and Folders

Edit any existing device or device folder.

Delete Devices and Folders

Delete any existing device or device folder.

Create Control Test Templates
and Folders

Create new control test templates and control test template folders.
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Edit Control Test Templates
and Folders

Edit any existing control test template or control test template folder.

Delete Control Test Templates
and Folders

Delete any existing control test template or control test template folder.

Create Users and User Groups

Create new users and user groups.

Edit Users and User Groups

Edit any existing user or user group.

Delete Users and User Groups

Delete any existing user or user group.

Create Station Groups

Create new station groups

Edit Stations and Station
Groups

Edit any existing station or station group.

Delete Stations and Station
Groups

Delete any existing station or station group.

Create Control Tests

Create new user-defined sample level control tests and user-defined
subgroup level control tests.

Edit Control Tests

Edit any existing user-defined sample level control test or user-defined
subgroup level control test.

Delete Control Tests

Delete any existing user-defined sample level control test or user-defined
subgroup level control test.

Apply Control Test Templates

Apply any existing control test template (done by right clicking on an item
and selecting the "Apply Template" option).

Create Lists and List Folders

Create new note lists, assignable cause lists, and corrective action lists
(WinSPC 8.0 or later only).

Edit Lists and List Folders

Edit any existing note list, assignable cause list, or corrective action list
(WinSPC 8.0 or later only).

Data Lists and List Folders

Delete any existing note list, assignable cause list, or corrective action list
(WInSPC 8.0 or later only).

Create List Links

Create new list links (done by dragging and dropping a list to a container
object) (WinSPC 8.0 or later only).

Delete List Links

Delete any existing list link (WinSPC 8.0 or later only).

Create Template Links

Create new template links (done by dragging and dropping a control test
template to a container object) (WinSPC 8.0 or later only).

Delete Template Links

Delete any existing template link (WinSPC 8.0 or later only).

Create Report Templates

Create new report templates and report template folders (WinSPC 8.0 or

later only).
. Edit any existing report template or report template folder (WinSPC 8.0 or
Edit Report Templates y grep P P P (
later only).
Delete any existing report template or report template folder (WinSPC 8.0 or
Delete Report Templates later only)

Manage Color Schemes

Access the "Tools" > "Chart Color Schemes" drop down menu item in the
"Administrator" window, giving the user the ability to create, edit, and delete
color schemes.

Permission

When this permission is granted, WinSPC allows the user to ...

Create Layout

Access the "Layout" > "New" drop down item and the "New Layout" toolbar
button, which when activated, creates a new Plant Monitor Layout.

Edit Layout

Make changes to any layout the user can open. Also gives access to the
"Layout" > "Save" and "Save As" drop down menu items and the "Save
Layout" toolbar button. which when activated, gives the user the ability the
save the layout and any changes made.
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Delete Layout

Access the "Layout” > "Delete" drop down menu item, which when
activated, gives the user the ability to delete existing layouts.

Chart Drill Down

Click on a subgroup of data on the Violation Browser chart and see the
"Chart Drill Down" window, showing the samples associated with the
subgroup, any subgroup violations, subgroup tag values, and any notes,
assignable causes, or corrective actions associated with the subgroup.

Chart Drill Down > Edit Data

Edit the samples of a subgroup through the "Chart Drill Down" window.

Chart Drill Down > Edit Tags

Edit the tag values of a subgroup through the "Chart Drill Down" window.

Chart Drill Down > Exclude
From Calculations

Exclude a subgroup from calculations through the "Chart Drill Down"
window.

Chart Drill Down > Edit Notes

Edit the notes, assignable causes, and corrective actions associated with a
subgroup through the "Chart Drill Down™ window.

Chart Drill Down >
Acknowledge Violations

Access the "Acknowledge" and "Acknowledge All" buttons in the "Violation
Browser", which give the user the ability to acknowledge violations that have
occurred in Data Collection.

Permission

When this permission is granted, WinSPC allows the user to ...

Create Query Books

Access to the "New Query" and "New Folder" buttons in the "Query
Selector" window. This permission also controls if a user can create
"DataSets" (introduced in WinSPC 8.0).

Edit Query Books

Access to the "Edit" button in the "Query Selector" window, which when
activated, gives the user the ability to make changes to any existing Query
Book. This permission also controls if a user can make changes to a
"DataSet" (introduced in WinSPC 8.0).

Delete Query Books

Access to the "Delete" button in the "Query Selector" window, which gives
the user the ability to delete any existing Query Book. This permissions
also controls if a user can delete a "DataSet" (introduced in WinSPC 8.0).

Chart Drill Down

Click on a subgroup of data on the chart that is displayed as a result of a
query and see the "Chart Drill Down" window, showing the samples
associated with the subgroup, any subgroup violations, subgroup tag
values, and any notes, assignable causes, or corrective actions associated
with the subgroup.

Chart Drill Down > Edit Data

Edit the samples of a subgroup through the "Chart Drill Down" window.

Chart Drill Down > Edit Tags

Edit the tag values of a subgroup through the "Chart Drill Down" window.

Chart Drill Down > Exclude
From Calculations

Exclude a subgroup from calculations through the "Chart Drill Down"
window.

Chart Drill Down > Edit Notes

Edit the notes, assighable causes, and corrective actions associated with a
subgroup through the "Chart Drill Down" window.

Permission

When this permission is granted, WinSPC allows the user to ...

Create Report Books

Create new report books and report book folders.

Edit Report Books

Edit any existing report book or report book folder.

Delete Report Books

Delete any existing report book or report book folder.

Print/Preview

Print or preview any existing report book.

Full Mail (Can Create New Mail)

Send and receive mail from within WinSPC.

Chart Options

Access the the chart options (done so by right clicking on a chart).

Chart Options > Change Chart
Type

Change the chart type by right clicking on a chart and selecting the desired
chart type.
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Chart Options > Scroll Bar

Access to the "Scroll Bar" option when right clicking on a chart, giving the
user the ability to turn on or off the scroll bar to view previously collected
data.

Chart Options > Print

Access to the "Print" option when right clicking on a chart, giving the user
the ability to print the chart.

Chart Options > Properties

Access to the "Properties" option when right clicking on a chart, which when
activated, displays the "Chart Properties" window.

Chart Options > Properties >
Appearance (Scheme)

View and edit the "Scheme" tab of the "Chart Properties" window, giving the
user the ability to change the color, size, and shape of various visual chart
elements (such as the limit lines or data lines).

Chart Options > Properties >
Chart Elements (Options)

View the "Options" tab of the "Chart Properties" window that contains the
various display options listed below.

Chart Options > Properties >
Chart Elements (Options) > Set
Default Chart Scales

Use the "Chart Scales" options, giving the user the ability to modify the
current chart's scaling properties.

Chart Options > Properties >
Chart Elements (Options) >
Control Limits

Turn the control limit lines on the chart on or off.

Chart Options > Properties >
Chart Elements (Options) >
Specification Limits

Turn the specification limit lines on the chart on or off.

Chart Options > Properties >
Chart Elements (Options) >
Target

Turn the target line on the chart on or off.

Chart Options > Properties >
Chart Elements (Options) >
Reasonable Limits

Turn the reasonable limit lines on the chart on or off.

Chart Options > Properties >
Chart Elements (Options) > +/-
3 Sigma

Turn the +/- 3 Sigma lines on the chart on or off (used on histograms only).

Chart Options > Properties >
Chart Elements (Options) >
Mean

Turn the mean line on the chart on or off (used on histograms only).

Chart Options > Properties >
Chart Elements (Options) >
Readings On

Turn the readings on the chart on or off.

Chart Options > Properties >
Chart Elements (Options) >
Vertical Grid Lines

Turn the vertical grid lines on the chart on or off.

Chart Options > Properties >
Chart Elements (Options) >
Histogram Bars

Access the "Histogram Settings - Bins" option, giving the user the ability to
control how many bins the histogram will use.

The table below represents a list of the possible WinSPC User or User Group permissions and what actions

each permission is related to.
Data Collection Permissions

Administration Permissions
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Plant Monitor Permissions
Analysis | Permissions

Global Permissions

https://knowledgebase.winspc.com/questions/145/
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